[LMI] Problème: Vista passe en Qwerty

Voir le sujet précédent Voir le sujet suivant Aller en bas

[LMI] Problème: Vista passe en Qwerty

Message  Wilbur le Sam 23 Fév 2008, 12:27

Bonjour,

Il y a peu, je me suis offert un portable, avec, évidemment, Vista comme OS. Et une fois de plus, il me cause des petits désagréments...

Je sais que ce post n'a pas directement d'affinité avec le cours de Microprocesseur, néanmoins, je rencontre ce problème lorsque j'y travaille. Enfin, quand je dis "je", ce sont plusieurs étudiants qui, dans leur plus grand désarroi, se retrouvent confrontés à ce problème, qui en soi, n'est pas vraiment grave, mais assez handicapant (personnellement, je suis habitué au qwerty, mais je ne poste pas que pour moi).

Le problème est le suivant:

Lors de l'écriture du code via un éditeur de texte : aucun problème.
C'est lorsque tasm, et l'édition de lien sont lancés que Dos passe tout simplement en qwerty. Ou encore, lors du changement du PATH, de l'édition d'un fichier sous Dos, ...
Par contre, nous n'avons jamais rencontré ce problème lors de la compilation ou l'exécution en java.

Nous en avons déjà parlé autour de nous, ainsi qu'à certains professeurs : en vain.

Je poste donc ici dans l'espoir que quelqu'un puisse nous aider à résoudre ce problème.

Merci d'avoir lu ce post,
Au plaisir.

Wilbur

Nombre de messages : 46
Age : 27
Prénom : Romain
Statut : Etudiant 2ème Réseaux
Date d'inscription : 20/02/2008

Revenir en haut Aller en bas

Re: [LMI] Problème: Vista passe en Qwerty

Message  pbt le Sam 23 Fév 2008, 13:45

(Je ne connais pas du tout Vista)

Quel est le programme utilisé comme interprêteur de commande ? cmd.com ou command.com ?
Existe-t-il encore les deux versions sur la même machine ? Si oui rencontres-tu le problème avec l'un comme avec l'autre.
Peux-tu essayer de lancer un interprêteur (au choix cmd.com ou command.com) récupéré sur une machine Windows 2000 et voir ce que cela donne.

_________________
smartq.namok.be · faq ·  · IRC / irc.freenode.net #esi · blog.namok.be
style #pbt {heigth:189cm; weight:79kg; eye-color:#524000; hair:very short; dead pixels: some; }

pbt
Admin

Nombre de messages : 4862
Age : 45
Prénom : Pierre
Statut : prof
Localisation : La cité des géants
Date d'inscription : 24/11/2005

http://esi.namok.be

Revenir en haut Aller en bas

Re: [LMI] Problème: Vista passe en Qwerty

Message  Wilbur le Sam 23 Fév 2008, 14:14

PbT a écrit:(Je ne connais pas du tout Vista)

Quel est le programme utilisé comme interprêteur de commande ? cmd.com ou command.com ?
Existe-t-il encore les deux versions sur la même machine ? Si oui rencontres-tu le problème avec l'un comme avec l'autre.

Lorsque j'utilise cmd.com, le problème est celui que j'ai exposé plus haut.
Mais quand j'essaie avec command.com, j'ai directement droit qwerty, sans passer par la case azerty.

PbT a écrit:Peux-tu essayer de lancer un interprêteur (au choix cmd.com ou command.com) récupéré sur une machine Windows 2000 et voir ce que cela donne.

Là il faut que j'essaie...

Sinon, on m'a proposé une solution : dual boot avec vista d'une part (dont je ne peux me séparer), et xp de l'autre. Mais s'il y avait moyen de régler tout ça sans devoir passer par là, ce serait intéressant.

Au plaisir.

Wilbur

Nombre de messages : 46
Age : 27
Prénom : Romain
Statut : Etudiant 2ème Réseaux
Date d'inscription : 20/02/2008

Revenir en haut Aller en bas

Re: [LMI] Problème: Vista passe en Qwerty

Message  cluigi le Sam 23 Fév 2008, 14:21

vmware avec un bete windows 2000 ça devrait être plus simple que le dual boot

sinon la dosbox

cluigi

Nombre de messages : 710
Age : 30
Prénom : Luigi
Statut : Ancienne star
Localisation : Bruxelles
Date d'inscription : 21/12/2006

http://stages2008.cluigi.be

Revenir en haut Aller en bas

Re: [LMI] Problème: Vista passe en Qwerty

Message  Gustavo le Sam 23 Fév 2008, 18:15

Salut,

essaye un peut en tapant la commande
Code:
kb16 fr
dans la console.

En principe tu resteras en azerty Smile

Pour que ça soit permanent tu peux rajouter cette commande dans ton fichier autoexec.nt dans system32 (l'editer en mode administrateur)

Sous XP pour ceux que ça interresse c'est pareil mais je crois que c'est le fichier autoexec.bat qu'il faut éditer (à vérifier).

voilà,
++

Gustavo

Nombre de messages : 260
Age : 29
Prénom : Renaud
Statut : étudiant 4SEC
Date d'inscription : 10/01/2008

Revenir en haut Aller en bas

Re: [LMI] Problème: Vista passe en Qwerty

Message  Iorek le Sam 23 Fév 2008, 18:36

maintient shift et appuye sur alt ? Very Happy

Iorek

Nombre de messages : 198
Age : 31
Prénom : Fabian
Statut : etd 3 ème réseaux
Localisation : Uccle
Date d'inscription : 03/11/2006

Revenir en haut Aller en bas

Re: [LMI] Problème: Vista passe en Qwerty

Message  REDrusromd le Dim 24 Fév 2008, 00:40

essaye un peut en tapant la commande

Code: kb16 fr dans la console

Ca marche, tres bien, merci Renaud

REDrusromd

Nombre de messages : 5
Prénom : Eduard
Date d'inscription : 24/01/2008

Revenir en haut Aller en bas

Re: [LMI] Problème: Vista passe en Qwerty

Message  Wilbur le Dim 24 Fév 2008, 18:57

En effet, ça a l'air de fonctionner.

Un grand merci papi Gustav Wink

Au plaisir.

Wilbur

Nombre de messages : 46
Age : 27
Prénom : Romain
Statut : Etudiant 2ème Réseaux
Date d'inscription : 20/02/2008

Revenir en haut Aller en bas

Re: [LMI] Problème: Vista passe en Qwerty

Message  Invité le Mar 04 Mar 2008, 11:35

j'ai un autre problème qui s'y rapporte étrangement...

Je compile un code en ASM avec tasm et compagnie... Je l'exécute avec Vista, mon clavier est en QWERTY (avec l'appel systeme 10 service 9)... Mais j'ai pris l'éxécutable compilé sous vista et je l'ai éxécuté à l'école, oh stupeur, mon clavier est en AZERTY...

J'ai tapé la commande kb16 be, j'ai recompilé et réexécuté l'exécutable dans la même console et le problème n'est plus là... mais exécuter l'exécutable en console ne m'interesse pas... J'aimerai double-cliquer sur l'icone et lancer le programme... C'est ce que j'ai fait mais le clavier est toujours en QWERTY...

J'aimerai un peu de lumière sur ce point obscur...

Herbiti

Invité
Invité


Revenir en haut Aller en bas

Re: [LMI] Problème: Vista passe en Qwerty

Message  wapiti le Mar 04 Mar 2008, 13:38

Pourtqnt c'est sympq le azerty

wapiti

Nombre de messages : 31
Prénom : Khris'
Date d'inscription : 07/09/2007

Revenir en haut Aller en bas

Re: [LMI] Problème: Vista passe en Qwerty

Message  the_red_skin le Mar 04 Mar 2008, 15:13

REDrusromd a écrit:
essaye un peut en tapant la commande

Code: kb16 fr dans la console

Ca marche, tres bien, merci Renaud

Oui c'est magique n'est-ce pas ?

the_red_skin

Nombre de messages : 473
Age : 30
Prénom : Martin
Statut : Ancien
Localisation : Arlon
Date d'inscription : 08/02/2006

Revenir en haut Aller en bas

Re: [LMI] Problème: Vista passe en Qwerty

Message  Contenu sponsorisé Aujourd'hui à 20:44


Contenu sponsorisé


Revenir en haut Aller en bas

Voir le sujet précédent Voir le sujet suivant Revenir en haut


 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum