(résolu) [MIC] installation de ALD

Voir le sujet précédent Voir le sujet suivant Aller en bas

(résolu) [MIC] installation de ALD

Message  jonas le Sam 24 Jan 2009, 11:46

(Sous UBUNTU 8.10)
Je ne parviens pas à installer ALD (assembly language debugger)

j'ai tenté de suivre la procédure du sylabus:

  • j'ai téléchargé ald-0.1.7.tar.gz
  • je l'ai décompressé

après exécution de "./config":
tout semble fonctionner.
Code:

Configuration:

  ald version:                    0.1.7
  Host:                          i686-pc-linux-gnu
  Install prefix:                /usr/local
  Compiler:                      gcc
  Compiler Flags:                -g -O2 -DNDEBUG
  Readline support:              disabled
  GTK gui:                        disabled

ald is now configured for your system. You can run make here.

après "make":


j'ai toute une panoplie d'erreurs de ce type:
(j'ai pas tout mis parce qu'il y en a une bonne quinzaine...)

Note: j'ai déjà mis en commentaire les lignes 25 et 30 du fichier readln.c comme indiqué dans le syllabus.

Code:

Making all in doc
make[1]: entrant dans le répertoire « /home/jonathan/Bureau/ald-0.1.7/doc »
make[1]: Rien à faire pour « all ».
make[1]: quittant le répertoire « /home/jonathan/Bureau/ald-0.1.7/doc »

Code:

make[2]: quittant le répertoire « /home/jonathan/Bureau/ald-0.1.7/libString/source »
make[2]: entrant dans le répertoire « /home/jonathan/Bureau/ald-0.1.7/libString »
make[2]: Rien à faire pour « all-am ».

Code:

make[4]: quittant le répertoire « /home/jonathan/Bureau/ald-0.1.7/libDebug/arch/ix86/source »
make[4]: entrant dans le répertoire « /home/jonathan/Bureau/ald-0.1.7/libDebug/arch/ix86 »
make[4]: Rien à faire pour « all-am ».
make[4]: quittant le répertoire « /home/jonathan/Bureau/ald-0.1.7/libDebug/arch/ix86 »
make[3]: quittant le répertoire « /home/jonathan/Bureau/ald-0.1.7/libDebug/arch/ix86 »
make[3]: entrant dans le répertoire « /home/jonathan/Bureau/ald-0.1.7/libDebug/arch »
make[3]: Rien à faire pour « all-am ».

Code:

make[1]: quittant le répertoire « /home/jonathan/Bureau/ald-0.1.7/source »
make[1]: entrant dans le répertoire « /home/jonathan/Bureau/ald-0.1.7 »
make[1]: Rien à faire pour « all-am ».
make[1]: quittant le répertoire « /home/jonathan/Bureau/ald-0.1.7 »

Merci à ceux qui pourront m'aider ! Smile


Dernière édition par jonas le Sam 24 Jan 2009, 12:42, édité 1 fois

jonas

Nombre de messages : 234
Prénom : Jonathan
Statut : Ancien industrialisé
Localisation : Devant son clavier BÉPO !
Date d'inscription : 29/09/2008

http://www.xax.be

Revenir en haut Aller en bas

Re: (résolu) [MIC] installation de ALD

Message  pbt le Sam 24 Jan 2009, 12:27

jonas a écrit:
j'ai toute une panoplie d'erreurs de ce type:
(j'ai pas tout mis parce qu'il y en a une bonne quinzaine...)

s'il est écrit qu'il "n'y a rien à faire" pour résoudre une cible, ce n'est probablement pas une "erreur". D'après les messages que tu reçois il semblerait que le boulot est fait ...

Essaie peut-être la suite.

Pbt qui aide sans avoir lu le syllabus (on peut me dir où on le trouve en PDF, pas dans edistri/nvs où je ne vois que les slides)

_________________
smartq.namok.be · faq ·  · IRC / irc.freenode.net #esi · blog.namok.be
style #pbt {heigth:189cm; weight:79kg; eye-color:#524000; hair:very short; dead pixels: some; }

pbt
Admin

Nombre de messages : 4862
Age : 45
Prénom : Pierre
Statut : prof
Localisation : La cité des géants
Date d'inscription : 24/11/2005

http://esi.namok.be

Revenir en haut Aller en bas

Re: (résolu) [MIC] installation de ALD

Message  jonas le Sam 24 Jan 2009, 12:31

Voici la procédure:


  • télécharger ald-0.1.7.tar.gz
  • décompresser ald-0.1.7.tar.gz
  • lire le fichier INSTALL
  • exécuter ./configure
  • exécuter make
  • en cas d'erreur lors du make:
    (a) éditer le fichier source/readln.c
    (b) mettre en commentaire les lignes 25 et 30 (deux lignes d'include)
  • exécuter make install, avec des droits d'administrateur
j'ai tenter d'exécuter le make install après le make mais cela génère également des erreurs.

jonas

Nombre de messages : 234
Prénom : Jonathan
Statut : Ancien industrialisé
Localisation : Devant son clavier BÉPO !
Date d'inscription : 29/09/2008

http://www.xax.be

Revenir en haut Aller en bas

Re: (résolu) [MIC] installation de ALD

Message  jonas le Sam 24 Jan 2009, 12:41

heuuu...

en effet le soft est installé Embarassed

on dirait qu'il s'est finalement installé mais en fait j'avoue que je ne sais pas pas trop quand !
Car j'ai fais de multiples installations...

enfin là maintenant la commande ald fonctionne !

en effet les erreurs (il y avait vraiment des "error [1]" au début!) ne s'affichent plus quand je lance make install
il n'y a plus que les messages de type
Code:

make[3]: Rien à faire pour « install-exec-am ».
make[3]: Rien à faire pour « install-data-am ».
je pensais que c'était des erreurs aussi et je n'avais pas retenté de lancer ald.

mais le soft fonctionne à présent

Merci Very Happy , et désolé pour le dérangement.

jonas

Nombre de messages : 234
Prénom : Jonathan
Statut : Ancien industrialisé
Localisation : Devant son clavier BÉPO !
Date d'inscription : 29/09/2008

http://www.xax.be

Revenir en haut Aller en bas

Re: (résolu) [MIC] installation de ALD

Message  nvs le Sam 24 Jan 2009, 14:40

le logiciel s'est installé dès la première fois que tu as exécuté
Code:
make install
avec des droits d'administrateur, après que tu as mis les deux lignes d'include en commentaire et que
Code:
make
a fait son boulot. les seuls error[1] qui sont apparus concernent ces fameuses 2 lignes, et, peut-être aussi, la tentative d'installation sans être root.

si je suis catégorique c'est parce que dans la description de ton problème, je ne vois aucune trace d'erreur lors du build et que dans la procédure de résolution que tu as suivie, tu ne sembles qu'avoir répété plusieurs fois la procédure renseignée dans le tutoriel, sans plus de manipulation Smile

j'insiste par contre sur un point : ald nécessite une distribution 32 bits. j'ai testé chez moi en 64 bits (ubuntu 8.10) : ça ne compile pas. et j'ai été bon pour installer une 32 bits Sad

à l'attention de pierre bettens --- qui, je le sens, commence à regretter d'avoir quitté l'équipe des 6 prêcheurs de l'ASM des derniers jours ---, une prise en main d'ald est disponible ici : http://nvansteenkiste.googlepages.com/lmi Wink








_________________

nvs

Nombre de messages : 5238
Age : 44
Prénom : Nicolas
Statut : prof
Localisation : bxl
Date d'inscription : 24/11/2005

http://nvansteenkiste.googlepages.com

Revenir en haut Aller en bas

Re: (résolu) [MIC] installation de ALD

Message  pbt le Sam 24 Jan 2009, 17:15

nvs a écrit:à l'attention de pierre bettens --- qui, je le sens, commence à regretter d'avoir quitté l'équipe des 6 prêcheurs de l'ASM des derniers jours ---, une prise en main d'ald est disponible ici : http://nvansteenkiste.googlepages.com/lmi Wink


Merci mon bon ... Je ne regrette rien c'est toujours ce soucis d'être au service des étudiants ...;-)

_________________
smartq.namok.be · faq ·  · IRC / irc.freenode.net #esi · blog.namok.be
style #pbt {heigth:189cm; weight:79kg; eye-color:#524000; hair:very short; dead pixels: some; }

pbt
Admin

Nombre de messages : 4862
Age : 45
Prénom : Pierre
Statut : prof
Localisation : La cité des géants
Date d'inscription : 24/11/2005

http://esi.namok.be

Revenir en haut Aller en bas

Re: (résolu) [MIC] installation de ALD

Message  nvs le Sam 24 Jan 2009, 17:22

PbT a écrit:
nvs a écrit:à l'attention de pierre bettens --- qui, je le sens, commence à regretter d'avoir quitté l'équipe des 6 prêcheurs de l'ASM des derniers jours ---, une prise en main d'ald est disponible ici : http://nvansteenkiste.googlepages.com/lmi Wink


Merci mon bon ... Je ne regrette rien c'est toujours ce soucis d'être au service des étudiants ...;-)
on ne t'en veut pas. la porte t'est toujours ouverte. dès l'an prochain si tu veux Wink














_________________

nvs

Nombre de messages : 5238
Age : 44
Prénom : Nicolas
Statut : prof
Localisation : bxl
Date d'inscription : 24/11/2005

http://nvansteenkiste.googlepages.com

Revenir en haut Aller en bas

Re: (résolu) [MIC] installation de ALD

Message  Madrid le Ven 13 Fév 2009, 23:12

salut les amis,

j'ai un problème à l'installation de ald même après avoir modifier les lignes include en commentaire voici l'erreur en fin de traitement


noor@noor-laptop:~/ald-0.1.7$ ./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking build system type... i686-pc-linux-gnulibc1
checking host system type... i686-pc-linux-gnulibc1
checking for gcc... gcc
checking for C compiler default output file name... configure: error: C compiler cannot create executables
See `config.log' for more details.
noor@noor-laptop:~/ald-0.1.7$

Merci.

Madrid

Nombre de messages : 187
Prénom : Noor
Statut : étudiant 2RET
Localisation : Woluwé-Saint-Lambert
Date d'inscription : 28/12/2006

Revenir en haut Aller en bas

Re: (résolu) [MIC] installation de ALD

Message  nvs le Sam 14 Fév 2009, 01:18

faudrait vraiment qu'un jour tu amènes ta bécane à l'école, car elle m'a l'air vraiment spéciale... sinon, quel est le contenu du fichier config.log ?



_________________

nvs

Nombre de messages : 5238
Age : 44
Prénom : Nicolas
Statut : prof
Localisation : bxl
Date d'inscription : 24/11/2005

http://nvansteenkiste.googlepages.com

Revenir en haut Aller en bas

Re: (résolu) [MIC] installation de ALD

Message  Madrid le Sam 14 Fév 2009, 01:26

Code:
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

It was created by ald configure 0.1.7, which was
generated by GNU Autoconf 2.59.  Invocation command line was

  $ ./configure

## --------- ##
## Platform. ##
## --------- ##

hostname = noor-laptop
uname -m = i686
uname -r = 2.6.22-14-generic
uname -s = Linux
uname -v = #1 SMP Sun Oct 14 23:05:12 GMT 2007

/usr/bin/uname -p = unknown
/bin/uname -X    = unknown

/bin/arch              = unknown
/usr/bin/arch -k      = unknown
/usr/convex/getsysinfo = unknown
hostinfo              = unknown
/bin/machine          = unknown
/usr/bin/oslevel      = unknown
/bin/universe          = unknown

PATH: /usr/local/sbin
PATH: /usr/local/bin
PATH: /usr/sbin
PATH: /usr/bin
PATH: /sbin
PATH: /bin
PATH: /usr/games


## ----------- ##
## Core tests. ##
## ----------- ##

configure:1333: checking for a BSD-compatible install
configure:1388: result: /usr/bin/install -c
configure:1399: checking whether build environment is sane
configure:1442: result: yes
configure:1507: checking for gawk
configure:1536: result: no
configure:1507: checking for mawk
configure:1523: found /usr/bin/mawk
configure:1533: result: mawk
configure:1543: checking whether make sets $(MAKE)
configure:1563: result: yes
configure:1731: checking whether to enable maintainer-specific portions of Makefiles
configure:1740: result: no
configure:1762: checking build system type
configure:1780: result: i686-pc-linux-gnulibc1
configure:1788: checking host system type
configure:1802: result: i686-pc-linux-gnulibc1
configure:1860: checking for gcc
configure:1876: found /usr/bin/gcc
configure:1886: result: gcc
configure:2130: checking for C compiler version
configure:2133: gcc --version </dev/null >&5
gcc (GCC) 4.1.3 20070929 (prerelease) (Ubuntu 4.1.2-16ubuntu2)
Copyright (C) 2006 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

configure:2136: $? = 0
configure:2138: gcc -v </dev/null >&5
Using built-in specs.
Target: i486-linux-gnu
Configured with: ../src/configure -v --enable-languages=c,c++,fortran,objc,obj-c++,treelang --prefix=/usr --enable-shared --with-system-zlib --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --enable-nls --with-gxx-include-dir=/usr/include/c++/4.1.3 --program-suffix=-4.1 --enable-__cxa_atexit --enable-clocale=gnu --enable-libstdcxx-debug --enable-mpfr --enable-checking=release i486-linux-gnu
Thread model: posix
gcc version 4.1.3 20070929 (prerelease) (Ubuntu 4.1.2-16ubuntu2)
configure:2141: $? = 0
configure:2143: gcc -V </dev/null >&5
gcc: '-V' option must have argument
configure:2146: $? = 1
configure:2169: checking for C compiler default output file name
configure:2172: gcc -g -O2  conftest.c  >&5
/usr/bin/ld: crt1.o: No such file: No such file or directory
collect2: ld returned 1 exit status
configure:2175: $? = 1
configure: failed program was:
| /* confdefs.h.  */
|
| #define PACKAGE_NAME "ald"
| #define PACKAGE_TARNAME "ald"
| #define PACKAGE_VERSION "0.1.7"
| #define PACKAGE_STRING "ald 0.1.7"
| #define PACKAGE_BUGREPORT ""
| #define PACKAGE "ald"
| #define VERSION "0.1.7"
| /* end confdefs.h.  */
|
| int
| main ()
| {
|
|  ;
|  return 0;
| }
configure:2214: error: C compiler cannot create executables
See `config.log' for more details.

## ---------------- ##
## Cache variables. ##
## ---------------- ##

ac_cv_build=i686-pc-linux-gnulibc1
ac_cv_build_alias=i686-pc-linux-gnulibc1
ac_cv_env_CC_set=
ac_cv_env_CC_value=
ac_cv_env_CFLAGS_set=
ac_cv_env_CFLAGS_value=
ac_cv_env_CPPFLAGS_set=
ac_cv_env_CPPFLAGS_value=
ac_cv_env_CPP_set=
ac_cv_env_CPP_value=
ac_cv_env_LDFLAGS_set=
ac_cv_env_LDFLAGS_value=
ac_cv_env_build_alias_set=
ac_cv_env_build_alias_value=
ac_cv_env_host_alias_set=
ac_cv_env_host_alias_value=
ac_cv_env_target_alias_set=
ac_cv_env_target_alias_value=
ac_cv_host=i686-pc-linux-gnulibc1
ac_cv_host_alias=i686-pc-linux-gnulibc1
ac_cv_path_install='/usr/bin/install -c'
ac_cv_prog_AWK=mawk
ac_cv_prog_ac_ct_CC=gcc
ac_cv_prog_make_make_set=yes

## ----------------- ##
## Output variables. ##
## ----------------- ##

ACLOCAL='${SHELL} /home/noor/ald-0.1.7/missing --run aclocal-1.9'
AMDEPBACKSLASH=''
AMDEP_FALSE=''
AMDEP_TRUE=''
AMTAR='${SHELL} /home/noor/ald-0.1.7/missing --run tar'
AUTOCONF='${SHELL} /home/noor/ald-0.1.7/missing --run autoconf'
AUTOHEADER='${SHELL} /home/noor/ald-0.1.7/missing --run autoheader'
AUTOMAKE='${SHELL} /home/noor/ald-0.1.7/missing --run automake-1.9'
AWK='mawk'
CC='gcc'
CCDEPMODE=''
CFLAGS='-g -O2'
CPP=''
CPPFLAGS=''
CYGPATH_W='echo'
DEFS=''
DEPDIR=''
ECHO_C=''
ECHO_N='-n'
ECHO_T=''
EGREP=''
EXEEXT=''
INSTALL_DATA='${INSTALL} -m 644'
INSTALL_PROGRAM='${INSTALL}'
INSTALL_SCRIPT='${INSTALL}'
INSTALL_STRIP_PROGRAM='${SHELL} $(install_sh) -c -s'
LDFLAGS=''
LIBOBJS=''
LIBS=''
LTLIBOBJS=''
MAINT='#'
MAINTAINER_MODE_FALSE=''
MAINTAINER_MODE_TRUE='#'
MAKEINFO='${SHELL} /home/noor/ald-0.1.7/missing --run makeinfo'
OBJEXT=''
PACKAGE='ald'
PACKAGE_BUGREPORT=''
PACKAGE_NAME='ald'
PACKAGE_STRING='ald 0.1.7'
PACKAGE_TARNAME='ald'
PACKAGE_VERSION='0.1.7'
PATH_SEPARATOR=':'
SET_MAKE=''
SHELL='/bin/bash'
STRIP=''
VERSION='0.1.7'
ac_ct_CC='gcc'
ac_ct_STRIP=''
am__fastdepCC_FALSE=''
am__fastdepCC_TRUE=''
am__include=''
am__leading_dot='.'
am__quote=''
am__tar='${AMTAR} chof - "$$tardir"'
am__untar='${AMTAR} xf -'
bindir='${exec_prefix}/bin'
build='i686-pc-linux-gnulibc1'
build_alias=''
build_cpu='i686'
build_os='linux-gnulibc1'
build_vendor='pc'
datadir='${prefix}/share'
exec_prefix='NONE'
host='i686-pc-linux-gnulibc1'
host_alias=''
host_cpu='i686'
host_os='linux-gnulibc1'
host_vendor='pc'
includedir='${prefix}/include'
infodir='${prefix}/info'
install_sh='/home/noor/ald-0.1.7/install-sh'
libdir='${exec_prefix}/lib'
libexecdir='${exec_prefix}/libexec'
localstatedir='${prefix}/var'
mandir='${prefix}/man'
mkdir_p='mkdir -p --'
oldincludedir='/usr/include'
prefix='NONE'
program_transform_name='s,x,x,'
sbindir='${exec_prefix}/sbin'
sharedstatedir='${prefix}/com'
subdirs=''
sysconfdir='${prefix}/etc'
target_alias=''

## ----------- ##
## confdefs.h. ##
## ----------- ##

#define PACKAGE "ald"
#define PACKAGE_BUGREPORT ""
#define PACKAGE_NAME "ald"
#define PACKAGE_STRING "ald 0.1.7"
#define PACKAGE_TARNAME "ald"
#define PACKAGE_VERSION "0.1.7"
#define VERSION "0.1.7"

Madrid

Nombre de messages : 187
Prénom : Noor
Statut : étudiant 2RET
Localisation : Woluwé-Saint-Lambert
Date d'inscription : 28/12/2006

Revenir en haut Aller en bas

Re: (résolu) [MIC] installation de ALD

Message  XavBod le Sam 14 Fév 2009, 14:29

Madrid a écrit:salut les amis,

j'ai un problème à l'installation de ald même après avoir modifier les lignes include en commentaire voici l'erreur en fin de traitement


noor@noor-laptop:~/ald-0.1.7$ ./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking build system type... i686-pc-linux-gnulibc1
checking host system type... i686-pc-linux-gnulibc1
checking for gcc... gcc
checking for C compiler default output file name... configure: error: C compiler cannot create executables
See `config.log' for more details.
noor@noor-laptop:~/ald-0.1.7$

Merci.

As tu essayé la commande
Code:
sudo apt-get install build-essential
?
moi j'avais ce problème et en tapant la commande, ald s'installait correctement apres.
Bonne chance !
clown

XavBod

Nombre de messages : 196
Age : 26
Prénom : Xavier
Statut : Etudiant 3eme indu
Localisation : Woluwe
Date d'inscription : 27/09/2008

Revenir en haut Aller en bas

Re: (résolu) [MIC] installation de ALD

Message  Madrid le Sam 14 Fév 2009, 22:22

XavBod a écrit:
Madrid a écrit:salut les amis,

j'ai un problème à l'installation de ald même après avoir modifier les lignes include en commentaire voici l'erreur en fin de traitement


noor@noor-laptop:~/ald-0.1.7$ ./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking build system type... i686-pc-linux-gnulibc1
checking host system type... i686-pc-linux-gnulibc1
checking for gcc... gcc
checking for C compiler default output file name... configure: error: C compiler cannot create executables
See `config.log' for more details.
noor@noor-laptop:~/ald-0.1.7$

Merci.

As tu essayé la commande
Code:
sudo apt-get install build-essential
?
moi j'avais ce problème et en tapant la commande, ald s'installait correctement apres.
Bonne chance !
clown

merci à toi.

Madrid

Nombre de messages : 187
Prénom : Noor
Statut : étudiant 2RET
Localisation : Woluwé-Saint-Lambert
Date d'inscription : 28/12/2006

Revenir en haut Aller en bas

Re: (résolu) [MIC] installation de ALD

Message  didi le Mar 10 Mar 2009, 18:08

moi aussi même problème

j'ai eu une message comme

Code:

Configuration:

  ald version:                    0.1.7
  Host:                          i686-pc-linux-gnu
  Install prefix:                /usr/local
  Compiler:                      gcc
  Compiler Flags:                -g -O2 -DNDEBUG
  Readline support:              disabled
  GTK gui:                        disabled

ald is now configured for your system. You can run make here.

après "make":

Code:

make[1]: Leaving directory `/home/dinesh/ald-0.1.7/source'
make: *** [all-recursive] Error 1

j'ai ouvert le fichier sourcr/readln.c et

en ligne 25 et 30 j'ai mis commentaire
Code:

/* #include "<readline/readline.h>" */

Code:

/* #include "<readline/history.h>" */


mais aprés

j'ai fais

Code:

make install

ça donne même message

Code:

make[2]: Nothing to be done for `install-exec-am'.
test -z "/usr/local/man/man8" || mkdir -p -- "/usr/local/man/man8"
mkdir: cannot create directory `/usr/local/man/man8': Permission denied
make[2]: *** [install-man8] Error 1
make[2]: Leaving directory `/home/didi/ald-0.1.7/doc'
make[1]: *** [install-am] Error 2
make[1]: Leaving directory `/home/didi/ald-0.1.7/doc'
make: *** [install-recursive] Error 1


quel qu'un peut m'aider ???

didi

Nombre de messages : 215
Prénom : Dinesh
Statut : Smile
Date d'inscription : 21/01/2009

Revenir en haut Aller en bas

Re: (résolu) [MIC] installation de ALD

Message  nvs le Mar 10 Mar 2009, 18:16

après avoir commenté les deux lignes, il faut réexécuter
Code:
make
puis
Code:
make install







_________________

nvs

Nombre de messages : 5238
Age : 44
Prénom : Nicolas
Statut : prof
Localisation : bxl
Date d'inscription : 24/11/2005

http://nvansteenkiste.googlepages.com

Revenir en haut Aller en bas

Re: (résolu) [MIC] installation de ALD

Message  didi le Mar 10 Mar 2009, 18:58

nvs a écrit:après avoir commenté les deux lignes, il faut réexécuter
Code:
make
puis
Code:
make install







j'ai essaié une fois même chose ...
j'ai mis de commentaire comme
Code:
 /* #include "<readline/history.h>" */
/* #include "<readline/readline.h>" */


epuis j'ai typé
Code:
make
epuis
Code:
make install
ça donne érruer message comme

Code:

Making install in doc
make[1]: Entering directory `/home/didi/ald-0.1.7/doc'
make[2]: Entering directory `/home/didi/ald-0.1.7/doc'
make[2]: Nothing to be done for `install-exec-am'.
test -z "/usr/local/man/man8" || mkdir -p -- "/usr/local/man/man8"
mkdir: cannot create directory `/usr/local/man/man8': Permission denied
make[2]: *** [install-man8] Error 1
make[2]: Leaving directory `/home/didi/ald-0.1.7/doc'
make[1]: *** [install-am] Error 2
make[1]: Leaving directory `/home/didi/ald-0.1.7/doc'
make: *** [install-recursive] Error 1

et j'ai essaié le fichier /usr/include/asm/unistd.h
dans ce fichir il n'y que ces text
Code:
 
# ifdef __i386__
#  include "unistd_32.h"
# else
#  include "unistd_64.h"
# endif

didi

Nombre de messages : 215
Prénom : Dinesh
Statut : Smile
Date d'inscription : 21/01/2009

Revenir en haut Aller en bas

Re: (résolu) [MIC] installation de ALD

Message  nvs le Mar 10 Mar 2009, 19:27

essaie de faire
Code:
make
avec les droits du superutilisateur... je suis un peu étonné car chez moi,
Code:
make
ne modifie rien sur la machine qui ne se trouve dans mon home (le répertoire aldxxx se trouve dans mon home). par contre, c'est
Code:
make install
qui a besoin d'être exécuté en root...




_________________

nvs

Nombre de messages : 5238
Age : 44
Prénom : Nicolas
Statut : prof
Localisation : bxl
Date d'inscription : 24/11/2005

http://nvansteenkiste.googlepages.com

Revenir en haut Aller en bas

Re: (résolu) [MIC] installation de ALD

Message  Dj x-fuse le Mar 10 Mar 2009, 19:37

didi a écrit:
et j'ai essaié le fichier /usr/include/asm/unistd.h
dans ce fichir il n'y que ces text
Code:
 
# ifdef __i386__
#  include "unistd_32.h"
# else
#  include "unistd_64.h"
# endif

Pour n'apporter qu'une partie de réponse à ton problème, Ubuntu étant distribué en version 32 et 64 bit, le set d'instruction des deux plateformes sont différentes, d'où l'utilité des deux fichiers.

Dans notre cas, nous utilisons le set d'instruction 32bit, il faut donc que tu utilises le fichier "unistd_32.h".

Si tu es sous Ubuntu 64bit, c'est légèrement différent :

Tu utiliseras toujours le fichier "unistd_32.h", mais la compilation de ton code se déroulera différemment.

Voici un petit code bash qui te compile et exécute ton code directement (à recommander aux flemmards de l'esi donc Very Happy )

Code:

#! /bin/bash
nasm printd.asm -o printd.o -f elf
nasm $1.asm -o $1.o -f elf
ld $1.o printd.o -o $1 -e main -m elf_i386
./$1

A suivre avec un "chmod 700 mon_script"

Exécution du script :

./mon_script mon_fichier_asm (sans l'extention !)

Dj x-fuse

Nombre de messages : 658
Age : 27
Prénom : Jonathan
Statut : 4ième sécu
Localisation : IRL
Date d'inscription : 18/10/2008

Revenir en haut Aller en bas

Re: (résolu) [MIC] installation de ALD

Message  didi le Jeu 12 Mar 2009, 18:19

ça va dire quoi " exécuter make install avec droits d'administrateur "
comme
Code:

chmod 800 make install
[code]

???

didi

Nombre de messages : 215
Prénom : Dinesh
Statut : Smile
Date d'inscription : 21/01/2009

Revenir en haut Aller en bas

Re: (résolu) [MIC] installation de ALD

Message  Dj x-fuse le Jeu 12 Mar 2009, 19:46

didi a écrit:ça va dire quoi " exécuter make install avec droits d'administrateur "
comme
Code:

chmod 800 make install

???

Lorsque tu compiles un programme, sous linux il y a différentes phases à exécuter comme : configurer le package (les sources de l'application), la compiler et l'installer sur ton disque dur.

Donc en gros, tu passe par ce genre de commande :
Code:

autoreconf --install --force
aclocal
autoheader
autoconf
automake --add-missing
automake src/bindings/.../Makefile
../configure --prefix=/... --sysconfdir=/... --datadir=/...
make -j n [n = nombre de coeur]
make install
make clean
C'est un exemple de la procédure de compilation d'un core que j'utilise sur linux...

Dans le cas de "chmod", cette commande permet de modifier les droits d'accès : lecture / écriture / exécution - parcours, d'un fichier ou d'un dossier.
Etant donné que chmod configure 3 droits d'accès (L'utilisateur, le groupe de l'utilisateur, les autres), on se retrouve dans un système octal :

000
001
010
011
100
101
110
111

Ce tableau te permet de configurer la lecture / écriture / exécution - parcours d'un seul utilisateur.
Pour configurer les 3 types d'utilisateur (à savoir : toi, ton groupe et les autres utilisateurs), il suffit de faire suivre ton code octal sur 9 caractères binaire.
Comme personne aime écrire en binaire, on passe à l'octal.

Ainsi, tu pourras écrire un chiffre entre 0 et 7 pour remplacer les 3 caractères binaires du dessus.

Au minimum, tu auras ceci :

- chmod 000 ... (qu'on utilise jamais bien entendu)

Au maximum, tu auras ceci :

- chmod 777



J'ai encore écrit un pavé, mais c'est pour le bien de l'humanité Laughing

Edit : Je me rends compte que je n'ai même pas répondu à la question posée, j'suis doué Razz


[edt nvs] j'ai viré une balise [code] du message original de didi histoire que la réponse soit bien mise en forme.


Dernière édition par Dj x-fuse le Jeu 12 Mar 2009, 20:22, édité 1 fois

Dj x-fuse

Nombre de messages : 658
Age : 27
Prénom : Jonathan
Statut : 4ième sécu
Localisation : IRL
Date d'inscription : 18/10/2008

Revenir en haut Aller en bas

Re: (résolu) [MIC] installation de ALD

Message  nvs le Jeu 12 Mar 2009, 20:16

didi a écrit:ça va dire quoi " exécuter make install avec droits d'administrateur "
comme
Code:

chmod 800 make install

???
non. plutôt comme :
Code:
su
(mot de passe du root)
make install
exit
ou
Code:
sudo make install
(ton mot de passe)
si tu es un sudoer Smile







Dernière édition par nvs le Jeu 12 Mar 2009, 20:22, édité 1 fois

_________________

nvs

Nombre de messages : 5238
Age : 44
Prénom : Nicolas
Statut : prof
Localisation : bxl
Date d'inscription : 24/11/2005

http://nvansteenkiste.googlepages.com

Revenir en haut Aller en bas

Re: (résolu) [MIC] installation de ALD

Message  pbt le Jeu 12 Mar 2009, 20:22

... et comme ça "make install" pourra copier les fichiers dans les répertoires qui vont bien (à savoir des répertoires dans lesquels un utilisateur normal n'a pas accès).

Rem: Didi est sous Ubuntu, donc il fera sudo.

_________________
smartq.namok.be · faq ·  · IRC / irc.freenode.net #esi · blog.namok.be
style #pbt {heigth:189cm; weight:79kg; eye-color:#524000; hair:very short; dead pixels: some; }

pbt
Admin

Nombre de messages : 4862
Age : 45
Prénom : Pierre
Statut : prof
Localisation : La cité des géants
Date d'inscription : 24/11/2005

http://esi.namok.be

Revenir en haut Aller en bas

Re: (résolu) [MIC] installation de ALD

Message  Contenu sponsorisé Aujourd'hui à 14:27


Contenu sponsorisé


Revenir en haut Aller en bas

Voir le sujet précédent Voir le sujet suivant Revenir en haut


 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum