[CPP]Problème Qt

Voir le sujet précédent Voir le sujet suivant Aller en bas

[CPP]Problème Qt

Message  bigmax le Sam 12 Mar 2011, 14:36

Bonjour j'ai un souci pour fini le jeu du pendu,
lorsque j'importe les classes métier, j'ai tout ce qui concerne le langage c/c++ souligné en rouge..

Par exemple string n'est pas reconnu, il faut le transformer en QString pour que cela fonctionne
pareil pour les méthodes de la bibliothèque standard c++

Une idée d'où vient le problème?

Merci

bigmax

Nombre de messages : 132
Age : 27
Prénom : Gilles
Statut : 3ème Réseaux
Date d'inscription : 17/11/2007

Revenir en haut Aller en bas

Re: [CPP]Problème Qt

Message  Terminatour le Sam 12 Mar 2011, 15:49

Une idée d'où vient le problème?
tu n'as pas lu le pdf en entier ...

il faut indiquer à eclipse où se trouvent les headers standards :
Project > Properties > C/C++ Include Paths and Symbols > Add External Include Path...
> Browse...
Ensuite :
– sous Ms-Windows installé comme à l’école, fournir le chemin :
C:/MinGW/lib/gcc/mingw32/4.5.0/include/c++

mais si tu l'as déjà fait tente un petit clean et build, vérifie les headers, un peu de magie vaudou et le using namespace std.

Terminatour

Nombre de messages : 344
Age : 25
Prénom : Louis-Julien
Statut : statutaire
Localisation : localisée
Date d'inscription : 04/10/2009

Revenir en haut Aller en bas

Re: [CPP]Problème Qt

Message  bigmax le Sam 12 Mar 2011, 16:34

Si si j'ai lu le pdf et j'ai bien suivi la consigne et ça ne fonctionne toujours pas malgré un clean + rebuild c'est pour ça que je viens poser la question ici avant de devenir fou Mad

Mais merci quand même pour ta réponse !

bigmax

Nombre de messages : 132
Age : 27
Prénom : Gilles
Statut : 3ème Réseaux
Date d'inscription : 17/11/2007

Revenir en haut Aller en bas

Re: [CPP]Problème Qt

Message  Terminatour le Sam 12 Mar 2011, 16:39

et t'es sûr que tes headers sont bons et le namespace ?

Terminatour

Nombre de messages : 344
Age : 25
Prénom : Louis-Julien
Statut : statutaire
Localisation : localisée
Date d'inscription : 04/10/2009

Revenir en haut Aller en bas

Re: [CPP]Problème Qt

Message  bigmax le Sam 12 Mar 2011, 17:51

oui j'ai même testé avec un .c test ou quand j'ajoute using namespace std;
ça me met : std is ambiguous

Si je créer un projet c++ classique la ça fonctionne sans problème donc je ne vois vraiment pas pourquoi ça ne marche pas
Sad

bigmax

Nombre de messages : 132
Age : 27
Prénom : Gilles
Statut : 3ème Réseaux
Date d'inscription : 17/11/2007

Revenir en haut Aller en bas

Re: [CPP]Problème Qt

Message  nvs le Sam 12 Mar 2011, 22:48

pas d'idée. envoie-moi ton projet eclipse qt. ou mieux, mets-le quelque part en ligne et ne m'envoie que l'url Smile








@

_________________

nvs

Nombre de messages : 5238
Age : 44
Prénom : Nicolas
Statut : prof
Localisation : bxl
Date d'inscription : 24/11/2005

http://nvansteenkiste.googlepages.com

Revenir en haut Aller en bas

Re: [CPP]Problème Qt

Message  bigmax le Dim 13 Mar 2011, 00:22

Bonsoir Mr. je vous ai envoyé mon code via votre adresse mail heb..
J'espère que vous pourrai m'aider sinon je suis mal barré Crying or Very sad

Bonne nuit.

bigmax

Nombre de messages : 132
Age : 27
Prénom : Gilles
Statut : 3ème Réseaux
Date d'inscription : 17/11/2007

Revenir en haut Aller en bas

Re: [CPP]Problème Qt

Message  nvs le Dim 13 Mar 2011, 10:04

j'ai bien reçu ton projet. au moment du build, j'ai eu un message d'erreur relatif au make. j'ai alors détruit les 3 makefiles et relancé un build qui est passé sans problème Very Happy








silent

_________________

nvs

Nombre de messages : 5238
Age : 44
Prénom : Nicolas
Statut : prof
Localisation : bxl
Date d'inscription : 24/11/2005

http://nvansteenkiste.googlepages.com

Revenir en haut Aller en bas

Re: [CPP]Problème Qt

Message  bigmax le Dim 13 Mar 2011, 11:13

Bonjour, même en détruisant les makefiles ça ne marche toujours pas.. Si j'importe le projet de quelqu'un d'autre ça ne marche pas non plus donc le problème doit venir de mon installation de MinGW ou eclipse Mad

Je crois que je suis bon pour le refaire à l'école demain..

bigmax

Nombre de messages : 132
Age : 27
Prénom : Gilles
Statut : 3ème Réseaux
Date d'inscription : 17/11/2007

Revenir en haut Aller en bas

Re: [CPP]Problème Qt

Message  nvs le Dim 13 Mar 2011, 11:27

bigmax a écrit:Bonjour, même en détruisant les makefiles ça ne marche toujours pas.. Si j'importe le projet de quelqu'un d'autre ça ne marche pas non plus donc le problème doit venir de mon installation de MinGW ou eclipse Mad
probablement Sad







No

_________________

nvs

Nombre de messages : 5238
Age : 44
Prénom : Nicolas
Statut : prof
Localisation : bxl
Date d'inscription : 24/11/2005

http://nvansteenkiste.googlepages.com

Revenir en haut Aller en bas

Re: [CPP]Problème Qt

Message  bigmax le Dim 13 Mar 2011, 12:48

Est ce possible que lors de l'installation du sdk Qt , il propose d'installer MinGW par défaut.. Je l'ai laissé coché lors de la première installation.. Peut être qu'il y a un conflit dans eclipse entre le MinGW de Qt et celui installé dans le c: ?

Je vais réinstaller ça.. mais ça me fait royalement ch... de passé mon temps la dessus

bigmax

Nombre de messages : 132
Age : 27
Prénom : Gilles
Statut : 3ème Réseaux
Date d'inscription : 17/11/2007

Revenir en haut Aller en bas

Re: [CPP]Problème Qt

Message  Wark le Dim 13 Mar 2011, 14:38

Effectivement, c'est bien c****. Maintenant, quand on se plante dans son install.... Rolling Eyes

Wark

Nombre de messages : 682
Age : 29
Prénom : Cédric
Statut : Diplômé 2010
Localisation : Braine l'alleud
Date d'inscription : 04/02/2008

Revenir en haut Aller en bas

Re: [CPP]Problème Qt

Message  bigmax le Dim 13 Mar 2011, 15:27

Même en réinstallant tout, ça ne marche toujours pas..
Je viens de faire la même chose sur un vieux pc en windows 32bits et la ça marche sans problème..

bigmax

Nombre de messages : 132
Age : 27
Prénom : Gilles
Statut : 3ème Réseaux
Date d'inscription : 17/11/2007

Revenir en haut Aller en bas

Re: [CPP]Problème Qt

Message  nvs le Dim 13 Mar 2011, 21:44

bigmax a écrit:Je viens de faire la même chose sur un vieux pc en windows 32bits et la ça marche sans problème..
si l'installation qui foire est sous windows 64 bits, le problème vient peut-être de l'utilisation d'une machine virtuelle java 64 bits avec un eclipse 32 bits (comme dans l'archive fournie).






Basketball

_________________

nvs

Nombre de messages : 5238
Age : 44
Prénom : Nicolas
Statut : prof
Localisation : bxl
Date d'inscription : 24/11/2005

http://nvansteenkiste.googlepages.com

Revenir en haut Aller en bas

Re: [CPP]Problème Qt

Message  bigmax le Lun 14 Mar 2011, 12:05

J'avais eu ce problème début janvier avec java 64 bits..
J'ai eclipse en 32 bits et le java jre 32bits ( comment vérififier que c'est bien une 32 bits? peut être que après une maj java il l'a remit en 64?)

Va savoir d'ou vient le problème scratch

bigmax

Nombre de messages : 132
Age : 27
Prénom : Gilles
Statut : 3ème Réseaux
Date d'inscription : 17/11/2007

Revenir en haut Aller en bas

Re: [CPP]Problème Qt

Message  bigmax le Jeu 17 Mar 2011, 18:41

Et oui c'est encore moi...
Les problèmes continuant et la date de remise de projet approchant j'ai vraiment besoin de trouver pourquoi ça bug
Est ce que quelqu'un pourrait tester en créant par exemple un Qt console project et voir si dans le main par exemple si quand on tape std::
y a-t-il une foule de possibilité ou non ?

Merci

bigmax

Nombre de messages : 132
Age : 27
Prénom : Gilles
Statut : 3ème Réseaux
Date d'inscription : 17/11/2007

Revenir en haut Aller en bas

Re: [CPP]Problème Qt

Message  smb le Jeu 17 Mar 2011, 20:15

bigmax a écrit:Et oui c'est encore moi...
Les problèmes continuant et la date de remise de projet approchant j'ai vraiment besoin de trouver pourquoi ça bug
Est ce que quelqu'un pourrait tester en créant par exemple un Qt console project et voir si dans le main par exemple si quand on tape std::
y a-t-il une foule de possibilité ou non ?

Merci

Je sais que ça ne résout probablement pas ton problème, mais le projet en mode console doit être un projet C++ normal, et pas un Qt console project !

Ce n'est que le GUI qui doit être fait en Qt !

smb

Nombre de messages : 1035
Age : 64
Prénom : Stéphan
Statut : Don de sang, don de vie!
Localisation : Spy
Date d'inscription : 23/01/2007

Revenir en haut Aller en bas

Re: [CPP]Problème Qt

Message  bigmax le Jeu 17 Mar 2011, 21:52

Merci, c'est déjà un bon conseil à prendre Smile
Quand je dis à eclipse d'aller chercher les headers standard dans C:/MinGW/lib/gcc/mingw32/4.5.0/include/c++ ;

Pour le td du pendu, j'ai repris un projet terminer que j'ai importer, qui compile et qui fonctionne bien..
Tant que que je ne modifie rien dans le projet, ça compile.. mais si je fais par exemple dans ce code :
Code:
void ObservateurProposition::rafraichir(SujetDObservation * sdo){
    QString prop("Proposition en cours :  \n");

    prop+=QString(pendu->motEnCours().c_str()+"\n  Essais restants :\n"+QString("").setNum(pendu->vie())+"\n";
    if(pendu->fini()){
       if(pendu->gagne()){
          prop+="Fini:Vous avez gagné !!!\n\n";
       }else{
          prop+=" <font color=red> Fini:Vous avez perdu  </font> \n";
          prop+="Le mot à trouver était:\n";
          prop+=pendu->solution().c_str();
       }
    }

   setText(prop);

}
si jamais je touche à pendu->motEnCours().c_str() et que je supprime .c_str() que je compile : erreur OK normal
mais si je le remet et que je recompile la ça ne marche plus..





tous attributs de type string de la classe pendu.h ne semble pas etre reconnu..

si je fais aussi par exemple :
string s = "bonjour";
s. ??
je n'ai aucune méthode de la classe string proposée..

Alors c'est grave docteur?

bigmax

Nombre de messages : 132
Age : 27
Prénom : Gilles
Statut : 3ème Réseaux
Date d'inscription : 17/11/2007

Revenir en haut Aller en bas

Re: [CPP]Problème Qt

Message  Contenu sponsorisé Aujourd'hui à 20:39


Contenu sponsorisé


Revenir en haut Aller en bas

Voir le sujet précédent Voir le sujet suivant Revenir en haut


 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum