[C++]Prob éclipse !

Voir le sujet précédent Voir le sujet suivant Aller en bas

[C++]Prob éclipse !

Message  LoopinG le Jeu 24 Nov 2011, 17:29

Hello tout le monde, je voulais entamer mon projet C++ mais je tombe sur un problème il ne reconnait pas certaines choses comme vector

Voici un screen du problème rencontré dans le OthelloOutils.h



En espérant que quelqu'un puisse m'aider à régler cela

LoopinG

Nombre de messages : 100
Prénom : Laurent
Statut : Étudiant en Réseaux et Télécoms
Localisation : L'hôpital de l'armée !
Date d'inscription : 24/03/2011

Revenir en haut Aller en bas

Re: [C++]Prob éclipse !

Message  smb le Jeu 24 Nov 2011, 18:09

Le problème vient peut-être d'un autre fichier de ton projet

Pour vérifier :
- crée un nouveau projet "Hello world c++ project";
- importe le header OthelloOutils.h dans le répertoire src ;
- inclus le header dans le source contenant le main ;
- sauve tout ;
- compile.

Si tu as encore des erreurs, c'est qu'il y a un problème dans ton installation.


smb

Nombre de messages : 1035
Age : 64
Prénom : Stéphan
Statut : Don de sang, don de vie!
Localisation : Spy
Date d'inscription : 23/01/2007

Revenir en haut Aller en bas

Re: [C++]Prob éclipse !

Message  LoopinG le Jeu 24 Nov 2011, 18:17

J'ai fait ce que vous m'avez dit et sa met le même problème !

Quand à l'installation j'ai suivi le fichier qui nous indique comment installer l'ensemble des logiciels comme à l'école !

Bizarre bizarre ... Sad

LoopinG

Nombre de messages : 100
Prénom : Laurent
Statut : Étudiant en Réseaux et Télécoms
Localisation : L'hôpital de l'armée !
Date d'inscription : 24/03/2011

Revenir en haut Aller en bas

Re: [C++]Prob éclipse !

Message  nvs le Jeu 24 Nov 2011, 18:18

s'agit-il d'un problème de compilation ou du parser de code d'eclipse ?





Suspect

_________________

nvs

Nombre de messages : 5238
Age : 44
Prénom : Nicolas
Statut : prof
Localisation : bxl
Date d'inscription : 24/11/2005

http://nvansteenkiste.googlepages.com

Revenir en haut Aller en bas

Re: [C++]Prob éclipse !

Message  LoopinG le Jeu 24 Nov 2011, 18:26

J'ai mis mon .h dans le source et là pas de problème identifié ! je compile et là j'ai ces 6 errors qui apparaissent

LoopinG

Nombre de messages : 100
Prénom : Laurent
Statut : Étudiant en Réseaux et Télécoms
Localisation : L'hôpital de l'armée !
Date d'inscription : 24/03/2011

Revenir en haut Aller en bas

Re: [C++]Prob éclipse !

Message  smb le Jeu 24 Nov 2011, 21:54

LoopinG a écrit:J'ai mis mon .h dans le source et là pas de problème identifié ! je compile et là j'ai ces 6 errors qui apparaissent

Dans le projet élémentaire que tu as créé, vois-tu un répertoire debug ?
Si oui, fais un delete de ce répertoire.
Ensuite, refais une compilation.
Le répertoire debug apparaît ou pas ?
Si oui, regarde son contenu.
Vois-tu un exe ?
Si oui, ça marche, ... mais les erreurs restent visibles !
Problème d'eclipse, allez savoir !

smb

Nombre de messages : 1035
Age : 64
Prénom : Stéphan
Statut : Don de sang, don de vie!
Localisation : Spy
Date d'inscription : 23/01/2007

Revenir en haut Aller en bas

Re: [C++]Prob éclipse !

Message  LoopinG le Jeu 24 Nov 2011, 22:13

smb a écrit:
LoopinG a écrit:J'ai mis mon .h dans le source et là pas de problème identifié ! je compile et là j'ai ces 6 errors qui apparaissent

Dans le projet élémentaire que tu as créé, vois-tu un répertoire debug ?
Si oui, fais un delete de ce répertoire.
Ensuite, refais une compilation.
Le répertoire debug apparaît ou pas ?
Si oui, regarde son contenu.
Vois-tu un exe ?
Si oui, ça marche, ... mais les erreurs restent visibles !
Problème d'eclipse, allez savoir !

j'ai fais tout ce que vous m'avez dit et j'ai encore les erreurs dans le .h !!!
Eclipse fait des siennes Sad

LoopinG

Nombre de messages : 100
Prénom : Laurent
Statut : Étudiant en Réseaux et Télécoms
Localisation : L'hôpital de l'armée !
Date d'inscription : 24/03/2011

Revenir en haut Aller en bas

Re: [C++]Prob éclipse !

Message  smb le Jeu 24 Nov 2011, 22:17

LoopinG a écrit:
smb a écrit:
LoopinG a écrit:J'ai mis mon .h dans le source et là pas de problème identifié ! je compile et là j'ai ces 6 errors qui apparaissent

Dans le projet élémentaire que tu as créé, vois-tu un répertoire debug ?
Si oui, fais un delete de ce répertoire.
Ensuite, refais une compilation.
Le répertoire debug apparaît ou pas ?
Si oui, regarde son contenu.
Vois-tu un exe ?
Si oui, ça marche, ... mais les erreurs restent visibles !
Problème d'eclipse, allez savoir !

j'ai fais tout ce que vous m'avez dit et j'ai encore les erreurs dans le .h !!!
Eclipse fait des siennes Sad

As-tu oui ou non un exécutable dans debug ?

smb

Nombre de messages : 1035
Age : 64
Prénom : Stéphan
Statut : Don de sang, don de vie!
Localisation : Spy
Date d'inscription : 23/01/2007

Revenir en haut Aller en bas

Re: [C++]Prob éclipse !

Message  LoopinG le Jeu 24 Nov 2011, 22:20

oui !

Et j'ai suivi tous vos conseils et même point !


Dernière édition par LoopinG le Jeu 24 Nov 2011, 22:20, édité 1 fois

LoopinG

Nombre de messages : 100
Prénom : Laurent
Statut : Étudiant en Réseaux et Télécoms
Localisation : L'hôpital de l'armée !
Date d'inscription : 24/03/2011

Revenir en haut Aller en bas

Re: [C++]Prob éclipse !

Message  smb le Jeu 24 Nov 2011, 22:20

LoopinG a écrit:oui !

Et bien alors, tout va bien !

smb

Nombre de messages : 1035
Age : 64
Prénom : Stéphan
Statut : Don de sang, don de vie!
Localisation : Spy
Date d'inscription : 23/01/2007

Revenir en haut Aller en bas

Re: [C++]Prob éclipse !

Message  LoopinG le Jeu 24 Nov 2011, 22:22

Si vous le dites ! :p

Merci de votre aide en tout cas !

LoopinG

Nombre de messages : 100
Prénom : Laurent
Statut : Étudiant en Réseaux et Télécoms
Localisation : L'hôpital de l'armée !
Date d'inscription : 24/03/2011

Revenir en haut Aller en bas

Re: [C++]Prob éclipse !

Message  smb le Jeu 24 Nov 2011, 22:24

LoopinG a écrit:Si vous le dites ! :p

Merci de votre aide en tout cas !

Tu n'as pas l'air de comprendre que si un exécutable est produit, le compilateur MinGW l'a produit et donc le reste est juste un problème de rafraîchissement d'eclipse.

Le principal est d'avoir un exécutable, non ?

smb

Nombre de messages : 1035
Age : 64
Prénom : Stéphan
Statut : Don de sang, don de vie!
Localisation : Spy
Date d'inscription : 23/01/2007

Revenir en haut Aller en bas

Re: [C++]Prob éclipse !

Message  nvs le Jeu 24 Nov 2011, 22:26

LoopinG a écrit:J'ai mis mon .h dans le source [...]
heu, ça veut dire quoi ?








Neutral

_________________

nvs

Nombre de messages : 5238
Age : 44
Prénom : Nicolas
Statut : prof
Localisation : bxl
Date d'inscription : 24/11/2005

http://nvansteenkiste.googlepages.com

Revenir en haut Aller en bas

Re: [C++]Prob éclipse !

Message  LoopinG le Jeu 24 Nov 2011, 22:26

smb a écrit:
LoopinG a écrit:Si vous le dites ! :p

Merci de votre aide en tout cas !

Tu n'as pas l'air de comprendre que si un exécutable est produit, le compilateur MinGW l'a produit et donc le reste est juste un problème de rafraîchissement d'eclipse.

Le principal est d'avoir un exécutable, non ?

OK mais ceci reste tout de même incompréhensible qu'un logiciel comme cela sorte des bug à tout va !

LoopinG

Nombre de messages : 100
Prénom : Laurent
Statut : Étudiant en Réseaux et Télécoms
Localisation : L'hôpital de l'armée !
Date d'inscription : 24/03/2011

Revenir en haut Aller en bas

Re: [C++]Prob éclipse !

Message  smb le Jeu 24 Nov 2011, 22:38

nvs a écrit:
LoopinG a écrit:J'ai mis mon .h dans le source [...]
heu, ça veut dire quoi ?
Neutral

La question de M. Vansteenkiste est pertinente !
As-tu fait :
#include "OthelloOutils.h" dans le fichier contenant le main ?

Fais-le, sauve, compile, et clique sur l'onglet OthelloOutils.h du projet.

smb

Nombre de messages : 1035
Age : 64
Prénom : Stéphan
Statut : Don de sang, don de vie!
Localisation : Spy
Date d'inscription : 23/01/2007

Revenir en haut Aller en bas

Re: [C++]Prob éclipse !

Message  LoopinG le Jeu 24 Nov 2011, 22:57

Là je n'ai plus les problèmes j'ai réenlevé ce include et là les problèmes sont plus dans le projet mais dans d'autres projets c++ notament le hello world du cours !

On dirait qu'il ne reconnait pas la librairie standard !

Ou une fois sur 2 mdr

ps : j'ai aussi "rebuild" l'index du projet et là les bug ont disparu !

Eclipse est un mystère ! Question Question Question Question

Merci pour votre aide dans tous les cas Smile

LoopinG

Nombre de messages : 100
Prénom : Laurent
Statut : Étudiant en Réseaux et Télécoms
Localisation : L'hôpital de l'armée !
Date d'inscription : 24/03/2011

Revenir en haut Aller en bas

Re: [C++]Prob éclipse !

Message  smb le Jeu 24 Nov 2011, 23:04

A mon avis tu n'as pas choisi Looping comme nom pour rien, non , cher capitaine Murdock Wink ?

smb

Nombre de messages : 1035
Age : 64
Prénom : Stéphan
Statut : Don de sang, don de vie!
Localisation : Spy
Date d'inscription : 23/01/2007

Revenir en haut Aller en bas

Re: [C++]Prob éclipse !

Message  LoopinG le Ven 25 Nov 2011, 09:31

Very Happy Va savoir !!! clown

LoopinG

Nombre de messages : 100
Prénom : Laurent
Statut : Étudiant en Réseaux et Télécoms
Localisation : L'hôpital de l'armée !
Date d'inscription : 24/03/2011

Revenir en haut Aller en bas

Re: [C++]Prob éclipse !

Message  Contenu sponsorisé Aujourd'hui à 18:58


Contenu sponsorisé


Revenir en haut Aller en bas

Voir le sujet précédent Voir le sujet suivant Revenir en haut


 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum