[Qt] Problème d'installation

Voir le sujet précédent Voir le sujet suivant Aller en bas

resolu [Qt] Problème d'installation

Message  Dj x-fuse le Lun 13 Fév 2012, 11:35

Bonjour à tous,

Ayant installé un nouvel environnement de développement Eclipse, je m'attaque maintenant à l'installation de la partie Qt. Hors, je rencontre un problème assez gênant !

En effet, après avoir suivi scrupuleusement le tuto disponible sur PoEsi, je me heurte à deux problèmes.

Le premier : A la création du projet Calculette (QWidget), ui_calculette.h n'est pas créer. J'ai donc deux messages :
calculette.cpp :
- Method 'setupUi' could not be resolved
calculette.h :
- Type 'Ui::CalculetteClass' could not be resolved
Voici une screen de l'IDE à ce moment :
http://img80.imageshack.us/img80/6025/capturedcran20120213112.png

Deuxième problème, make, make clean, qmake, etc ne sont pas reconnus. Hors, il me semble que tout soit bien paramétré dans Eclipse et j'ai ceci dans mon PATH :
C:\MinGW\bin;C:\Qt\4.7.3\bin\;C:\Program Files\Graphviz 2.28\bin;C:\Program Files\doxygen\bin
Je suis en compte admin sous Windows 7 Pro.


Dernière édition par Dj x-fuse le Mar 14 Fév 2012, 11:45, édité 1 fois

Dj x-fuse

Nombre de messages : 658
Age : 27
Prénom : Jonathan
Statut : 4ième sécu
Localisation : IRL
Date d'inscription : 18/10/2008

Revenir en haut Aller en bas

resolu Re: [Qt] Problème d'installation

Message  smb le Lun 13 Fév 2012, 11:49

Pour le deuxième problème, as-tu bien fait dans eclipse : Window >> preferences >> Qt etc...

Pour le premier, as-tu fait un "build all" ?

smb

Nombre de messages : 1035
Age : 64
Prénom : Stéphan
Statut : Don de sang, don de vie!
Localisation : Spy
Date d'inscription : 23/01/2007

Revenir en haut Aller en bas

resolu Re: [Qt] Problème d'installation

Message  Dj x-fuse le Lun 13 Fév 2012, 12:19

smb a écrit:Pour le deuxième problème, as-tu bien fait dans eclipse : Window >> preferences >> Qt etc...
Oui, les path ont directement été reconnus.

smb a écrit:Pour le premier, as-tu fait un "build all" ?
Oui et j'ai le même problème :/

Dj x-fuse

Nombre de messages : 658
Age : 27
Prénom : Jonathan
Statut : 4ième sécu
Localisation : IRL
Date d'inscription : 18/10/2008

Revenir en haut Aller en bas

resolu Re: [Qt] Problème d'installation

Message  smb le Lun 13 Fév 2012, 12:26

Et le path suivant :

"C:\MinGW\msys\1.0\bin\;"


[edt] Pour le premier problème dont tu parles, as-tu fait : clic droit sur le projet, ensuite Index >> Rebuild ? [/edt]

smb

Nombre de messages : 1035
Age : 64
Prénom : Stéphan
Statut : Don de sang, don de vie!
Localisation : Spy
Date d'inscription : 23/01/2007

Revenir en haut Aller en bas

resolu Re: [Qt] Problème d'installation

Message  Dj x-fuse le Lun 13 Fév 2012, 12:40

smb a écrit:Et le path suivant :

"C:\MinGW\msys\1.0\bin\;"
Ah oui, j'ai oublié de mentionner que dans MinGW je n'ai pas de dossier msys.


smb a écrit:[edt] Pour le premier problème dont tu parles, as-tu fait : clic droit sur le projet, ensuite Index >> Rebuild ? [/edt]
Oui ce fût mon premier reflex car il connaissait pas QApplication & co, mais cela ne change rien.

Dj x-fuse

Nombre de messages : 658
Age : 27
Prénom : Jonathan
Statut : 4ième sécu
Localisation : IRL
Date d'inscription : 18/10/2008

Revenir en haut Aller en bas

resolu Re: [Qt] Problème d'installation

Message  smb le Lun 13 Fév 2012, 13:20

Quand je retire le path "C:\MinGW\msys\1.0\bin\;" j'ai des problèmes semblables aux tiens !
(C'est bizarre que le répertoire msys ne soit pas présent dans ton répertoire MinGW !)

Je me souviens aussi d'un problème lorsque "C:\MinGW\bin;" n'était pas en tête du path complet !

smb

Nombre de messages : 1035
Age : 64
Prénom : Stéphan
Statut : Don de sang, don de vie!
Localisation : Spy
Date d'inscription : 23/01/2007

Revenir en haut Aller en bas

resolu Re: [Qt] Problème d'installation

Message  Dj x-fuse le Lun 13 Fév 2012, 18:09

Ok, merci pour la précision, je vais voir pourquoi j'ai pas ce dossier.

Bonne soirée

Dj x-fuse

Nombre de messages : 658
Age : 27
Prénom : Jonathan
Statut : 4ième sécu
Localisation : IRL
Date d'inscription : 18/10/2008

Revenir en haut Aller en bas

resolu Re: [Qt] Problème d'installation

Message  Dj x-fuse le Mar 14 Fév 2012, 11:45

En réinstallant MinGW avec msys cette-fois cela fonctionne bien mieux Smile

Problème résolu donc, merci !

Dj x-fuse

Nombre de messages : 658
Age : 27
Prénom : Jonathan
Statut : 4ième sécu
Localisation : IRL
Date d'inscription : 18/10/2008

Revenir en haut Aller en bas

resolu Re: [Qt] Problème d'installation

Message  Contenu sponsorisé Aujourd'hui à 18:56


Contenu sponsorisé


Revenir en haut Aller en bas

Voir le sujet précédent Voir le sujet suivant Revenir en haut


 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum