Problem de configuration de Eclipse Juno

Voir le sujet précédent Voir le sujet suivant Aller en bas

Problem de configuration de Eclipse Juno

Message  didi le Jeu 27 Sep 2012, 13:15

bonjour je viens d'installer le Eclipse Juno ( J'ai suivi les etapes qui sont données par Guide d'installation 2012-2013 )

j'arrive pas créer et executer les projets ( J'ai des erreurs de compilation )

Error 127 occurred while running autoreconf
make: *** No rule to make target `all'.
make: *** No rule to make target `clean'.


le variable PATH contient aussi (C:\MinGW\bin;C:\MinGW\msys\1.0\bin\;)











le Makefile (qui se trouve dans le Projet ) contient :
Code:
SUBDIRS=src

le Makefile (qui se trouve dans le Projet/src ) contient :

Code:
bin_PROGRAMS=a.out
a_out_SOURCES=Hello World.cpp


J'ai cherché sur internet mais j'arrive pas resoudre :-(

http://stackoverflow.com/questions/3714852/make-no-rule-to-make-target-all-stop-eclipse-error
http://stackoverflow.com/questions/9886211/make-no-rule-to-make-target-all-stop

merci d'avance


didi

Nombre de messages : 215
Prénom : Dinesh
Statut : Smile
Date d'inscription : 21/01/2009

Revenir en haut Aller en bas

Re: Problem de configuration de Eclipse Juno

Message  pbt le Jeu 27 Sep 2012, 13:35

Essaie «HelloWorld» au lieu de «Hello World» comme nom de fichier ...

_________________
smartq.namok.be · faq ·  · IRC / irc.freenode.net #esi · blog.namok.be
style #pbt {heigth:189cm; weight:79kg; eye-color:#524000; hair:very short; dead pixels: some; }

pbt
Admin

Nombre de messages : 4862
Age : 45
Prénom : Pierre
Statut : prof
Localisation : La cité des géants
Date d'inscription : 24/11/2005

http://esi.namok.be

Revenir en haut Aller en bas

Re: Problem de configuration de Eclipse Juno

Message  didi le Jeu 27 Sep 2012, 13:46

Merci ,
ça ne marche pas non plus avec HelloWorld
je pense que le probleme vien du avec le MakeFile(s)
car leur contenu est vide ( ou presque )

et j'ai importé des projets aussi pour tester ( toujour les mêmes erreurs ) .. :-(

didi

Nombre de messages : 215
Prénom : Dinesh
Statut : Smile
Date d'inscription : 21/01/2009

Revenir en haut Aller en bas

Re: Problem de configuration de Eclipse Juno

Message  Dj x-fuse le Jeu 27 Sep 2012, 14:05

Un autre étudiant rencontre le même problème, as-tu toi aussi gardé une ancienne version de mingw ?
Je demande ça, mais je ne sais pas si il existe (et si l'esi) utilise une nouvelle version de mingw. Dans le cas où il y aurait une nouvelle version, le prob viendrait-il d'une compatibilité non prise en compte ?

Dj x-fuse

Nombre de messages : 658
Age : 27
Prénom : Jonathan
Statut : 4ième sécu
Localisation : IRL
Date d'inscription : 18/10/2008

Revenir en haut Aller en bas

Re: Problem de configuration de Eclipse Juno

Message  didi le Jeu 27 Sep 2012, 14:10

non je n'ai pas gardé les ancien version , j'ai tous vidé (j'ai même formaté .. ) donc je n'ai plus de traces de l'année derniers
mais j'ai un system de 64 bits .
je ne pense pas ça produit des problem car j'ai pas eu les problem l'anné dernier avec le version 32 bits


didi

Nombre de messages : 215
Prénom : Dinesh
Statut : Smile
Date d'inscription : 21/01/2009

Revenir en haut Aller en bas

Re: Problem de configuration de Eclipse Juno

Message  karemkadidola le Jeu 27 Sep 2012, 15:25

J'ai exactement le même problème
installation à neuf.à partir des fichiers de l'école.
toutes les étapes suivies à la rigueur.
j'arrive à exécuter mes anciens projets que j'ai importé. au prix de virer les fichiers (makefile , makefile.Debug, makefile.Release, et les deux fichiers object_script ....) et un rebuild de l'index.
mais une fois que j'ouvre les fichiers d'un projet qui vient de fonctionner i ...là je vois rouge...plus rien n'est reconnu avec les fameux message "symbol .... could not be resolved"

karemkadidola

Nombre de messages : 244
Prénom : aimé
Date d'inscription : 13/10/2009

Revenir en haut Aller en bas

Re: Problem de configuration de Eclipse Juno

Message  nvs le Jeu 27 Sep 2012, 16:04

c'est quoi gnu autotools ? perso, je développe des exécutables :


plus de détails dans l'ex00 du td_c1.






cat

_________________

nvs

Nombre de messages : 5238
Age : 44
Prénom : Nicolas
Statut : prof
Localisation : bxl
Date d'inscription : 24/11/2005

http://nvansteenkiste.googlepages.com

Revenir en haut Aller en bas

Re: Problem de configuration de Eclipse Juno

Message  karemkadidola le Jeu 27 Sep 2012, 17:28

MERCI monsieur, je me suis bien fait avoir en effet ça marche beaucoup mieux maintenant

karemkadidola

Nombre de messages : 244
Prénom : aimé
Date d'inscription : 13/10/2009

Revenir en haut Aller en bas

Re: Problem de configuration de Eclipse Juno

Message  didi le Jeu 27 Sep 2012, 19:52

Merci :-)

maintenat mon projet qui fonctionne (j'arrive à executer) mais j'ai des erreur de compilation :-(


didi

Nombre de messages : 215
Prénom : Dinesh
Statut : Smile
Date d'inscription : 21/01/2009

Revenir en haut Aller en bas

Re: Problem de configuration de Eclipse Juno

Message  mvh le Jeu 27 Sep 2012, 20:50

super Smile

_________________

La fête c'est nul sans Kidibul !
... (vieux proverbe local)



mvh

Nombre de messages : 5973
Age : 104
Prénom : Marcel VANHAELEN
Statut : (fin de bail)
Win 3.1 à reprendre
Localisation : Koekeliek de Baselberg
Date d'inscription : 06/12/2006

Revenir en haut Aller en bas

Re: Problem de configuration de Eclipse Juno

Message  karemkadidola le Ven 28 Sep 2012, 01:23

didi comme t'as dû le remarquer comme moi on ne choisissait pas le bon type de projet en tout cas pas dans bonne catégorie (exécutable).... maintenant que je crois ce problème de création d'un nouveau projet résolu chez toi aussi grâce à la judicieuse remarque de mr nvs je cite " c'est quoi un gnu autotools " très bonne question en effet au fait c'est vrai c'est quoi gnu autotools ?? je pense qu'on a pas besoin de le savoir pour l'instant sinon qu'il nous sert pas à créer des exécutables 'fin ...bon apparemment tu as plutôt des soucis avec tes projets importés (je vois sur l'image qu'il s'agit du projet Othello de l'année passée et non de test2 que tu as dû créer maintenat pour tester un nouveau projet )
Pour cela tu dois virer les makefiles d'origine avec les autres fichiers que tu verras dans mon premier post.(un total des 5 fichiers si je ne m'abuse ...essentiellement pour les projets avec interface graphique) car c'est basé sur ton ancienne config eclipse et compilo mingw.(contenu du path totalement incompatible) après avoir viré ces 5 fichiers tu commences par reconstruire l'index pour ça tu fais click droit sur le projet puis tu selectionne "index" -> "rebuild" après tu fais un "clean" de ton projet ceci va te régénérer les fichiers que tu as supprimer tantôt c'est à dire makefile et les 4 autes fichiers...sur base de ta nouvelle config..version mingw, eclipse ... et là tu fais un build de ton projet qui va se baser sur le makefile nouvellement créer pour te générer un exécutable en bonne et dû forme.
En toute logique de cause tout devrait bien marcher..sinon tu sais cmt me contacter et on en discute allez good luck brave didi !!

karemkadidola

Nombre de messages : 244
Prénom : aimé
Date d'inscription : 13/10/2009

Revenir en haut Aller en bas

Re: Problem de configuration de Eclipse Juno

Message  Contenu sponsorisé Aujourd'hui à 09:26


Contenu sponsorisé


Revenir en haut Aller en bas

Voir le sujet précédent Voir le sujet suivant Revenir en haut


 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum